Security Advisory

Back to advisories

Multiple XSS vulnerabilities (oC-SA-2013-028)

6th June 2013

Risk level: Medium

Description

Cross-site scripting (XSS) vulnerabilities in js/viewer.js inside the files_videoviewer application via multiple unspecified vectors in all ownCloud versions prior to 5.0.7 and 4.5.12 allows authenticated remote attackers to inject arbitrary web script or HTML via shared files. (CVE-2013-2150)

Cross-site scripting (XSS) vulnerabilities in core/js/oc-dialogs.js via multiple unspecified vectors in all ownCloud versions prior to 5.0.7 and other versions before 4.0.16 allows authenticated remote attackers to inject arbitrary web script or HTML via shared files. (CVE-2013-2149)

Affected Software

  • ownCloud Server < 5.0.7 (CVE-2013-2150, CVE-2013-2149)
  • ownCloud Server < 4.5.12 (CVE-2013-2150, CVE-2013-2149)
  • ownCloud Server < 4.0.16 (CVE-2013-2149)

Action Taken

It is recommended that all instances are upgraded to ownCloud Server 5.0.7.

Acknowledgements

The ownCloud team thanks the following people for their research and responsible disclosure of the above advisory:

  • Mateusz Goik - AliantSoft - Vulnerability discovery and disclosure.