Security Advisory

Back to advisories

Privilege escalation and CSRF in the API (oC-SA-2013-025)

14th May 2013

Risk level: Medium

Description

Due to an insufficient permission check, an authenticated attacker is able to execute API commands as administrator. Additionally, an unauthenticated attacker could abuse this flaw as a cross-site request forgery vulnerability.

Affected Software

  • ownCloud Server < 5.0.6 (CVE-2013-2048)

Action Taken

It is recommended that all instances are upgraded to ownCloud Server 5.0.6.

Acknowledgements

The ownCloud team thanks the following people for their research and responsible disclosure of the above advisory:

  • Lukas Reschke - ownCloud Inc. (lukas@owncloud.org) - Vulnerability discovery and disclosure.