Security Advisory

Back to advisories

XSS vulnerability in user_webdavauth (oC-SA-2012-003)

14th November 2012

Risk level: Medium

Description

A cross-site scripting (XSS) vulnerability in ownCloud 4.5.x before 4.5.2 allow remote attackers to inject arbitrary web script or HTML via the POST data to settings.php in apps/user_webdavauth/

Affected Software

  • ownCloud Server < 4.5.2 (CVE-2012-5608)

Action Taken

It is recommended that all instances are upgraded to ownCloud Server 4.5.2.

Acknowledgements

The ownCloud team thanks the following people for their research and responsible disclosure of the above advisory:

  • Lukas Reschke - ownCloud Inc. (lukas@owncloud.org) - Vulnerability discovery and disclosure.