Security Advisory

Back to advisories

Multiple XSS vulnerabilities (oC-SA-2012-001)

24th August 2012

Risk level: Medium

Description

Multiple cross-site scripting (XSS) vulnerabilities in ownCloud 4.5.0 allow remote attackers to inject arbitrary web script or HTML via

  • the filename to to versions.js in apps/files_versions/js/
  • the filename to filelist.js in apps/files/js/
  • the event title to fullcalendar.js in 3rdparty/fullcalendar/js/

Affected Software

  • ownCloud Server < 4.5.1 (CVE-2012-5605)
  • ownCloud Server < 4.0.9 (CVE-2012-5605)

Action Taken

It is recommended that all instances are upgraded to ownCloud Server 4.5.1 or 4.0.10.

Acknowledgements

The ownCloud team thanks the following people for their research and responsible disclosure of the above advisory:

  • Shai Rod - Vulnerability discovery and disclosure.