< go back to overview

XXE in multiple third party components

Platform: ownCloud Server

Versions: 5.0.15, 6.0.2,

Date: 7/3/2014

Risk level: High

Description

Multiple third party components of ownCloud are vulnerable to XXE attacks, which may lead to:

  • Local File Disclosure
  • Server Side Request Forgery
  • DoS
  • Code Execution (depending on the PHP wrappers)

The following libraries are affected:

  • ZendFramework: CVE-2014-2052
  • GetID3: CVE-2014-2053
  • PHPExcel: CVE-2014-2054
  • SabreDAV: CVE-2014-2055
  • PHPDocX: CVE-2014-2056

Affected Software

  • ownCloud Server < 6.0.2 ()
  • ownCloud Server < 5.0.15 ()

Action Taken

All vendors except PHPDocX have released an update. PHPDocX states that the admin is responsible to validate the DOCX document and is considering this as won’t fix.

Acknowledgements

The ownCloud team thanks the following people for their research and responsible disclosure of the above advisory:

  • Lukas Reschke – ownCloud Inc. (lukas@owncloud.org) – Vulnerability discovery and disclosure.

Share this