< go back to overview

XSS Vulnerability in jPlayer

Platform: ownCloud Server

Versions: 4.0.14, 4.5.9, 5.0.4,

Date: 4/11/2013

Risk level: Medium

Description

A cross-site scripting (XSS) vulnerability in all ownCloud versions prior to 5.0.5 including the 4.0.x branch allows remote attackers to execute arbitrary javascript when a user opens a special crafted URL.

This vulnerability exists in the bundled 3rdparty plugin “jPlayer”, “jPlayer” released version 2.2.20 which addresses the problem.

Affected Software

  • ownCloud Server < 5.0.4 (CVE-2013-1942)
  • ownCloud Server < 4.5.9 (CVE-2013-1942)
  • ownCloud Server < 4.0.14 (CVE-2013-1942)

Action Taken

It is recommended that all instances are upgraded to ownCloud Server 5.0.4, 4.5.9 or 4.0.14.

Acknowledgements

The ownCloud team thanks the following people for their research and responsible disclosure of the above advisory:

  • Malte Batram – Vulnerability discovery and disclosure.

Share this

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close