< go back to overview

user_migrate: Local file disclosure

Platform: ownCloud Server

Versions: 4.0.13, 4.5.8,

Date: 3/14/2013

Risk level: High

Description

Incomplete blacklist vulnerability in lib/migrate.php in ownCloud before 4.0.13 and 4.5.8 allows an authenticated remote attacker to import arbitrary files on the server inside his user account.

Affected Software

  • ownCloud Server < 4.5.8 (CVE-2013-1851)
  • ownCloud Server < 4.0.13 (CVE-2013-1851)

Action Taken

It is recommended that all instances are upgraded to ownCloud Server 4.5.9 or 4.0.13.

Acknowledgements

The ownCloud team thanks the following people for their research and responsible disclosure of the above advisory:

  • Lukas Reschke – ownCloud Inc. (lukas@owncloud.org) – Vulnerability discovery and disclosure.

Share this

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close