< go back to overview

Multiple XSS vulnerabilities

Platform: ownCloud Server

Versions: 4.0.16, 4.5.12, 5.0.7,

Date: 6/6/2013

Risk level: Medium

Description

Cross-site scripting (XSS) vulnerabilities in js/viewer.js inside the files_videoviewer application via multiple unspecified vectors in all ownCloud versions prior to 5.0.7 and 4.5.12 allows authenticated remote attackers to inject arbitrary web script or HTML via shared files. (CVE-2013-2150)

Cross-site scripting (XSS) vulnerabilities in core/js/oc-dialogs.js via multiple unspecified vectors in all ownCloud versions prior to 5.0.7 and other versions before 4.0.16 allows authenticated remote attackers to inject arbitrary web script or HTML via shared files. (CVE-2013-2149)

Affected Software

  • ownCloud Server < 5.0.7 (CVE-2013-2150, CVE-2013-2149)
  • ownCloud Server < 4.5.12 (CVE-2013-2150, CVE-2013-2149)
  • ownCloud Server < 4.0.16 (CVE-2013-2149)

Action Taken

It is recommended that all instances are upgraded to ownCloud Server 5.0.7.

Acknowledgements

The ownCloud team thanks the following people for their research and responsible disclosure of the above advisory:

  • Mateusz Goik – AliantSoft – Vulnerability discovery and disclosure.

Share this

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close