< go back to overview

Multiple XSS vulnerabilities

Platform: ownCloud Server

Versions: 4.5.8,

Date: 3/14/2013

Risk level: Medium

Description

Multiple cross-site scripting (XSS) vulnerabilities in ownCloud 4.5.8 and all prior versions (except 4.0.x) allow remote attackers to inject arbitrary web script or HTML via

  • the “quota” POST parameter to setquota.php in /core/settings/ajax/
    • Commits: 2364c79 (stable45)
    • Risk: Low
    • Note: Successful exploitation of this stored XSS requires administrator privileges.
  • the group input field to settings.php
    • Commits: 4cff6df (stable45)
    • Risk: Low
    • Note: Successful exploitation of this DOM based self XSS requires group admin privileges.
  • the share with input field
    • Commits: 7b0a8f4 (stable45)
    • Risk: Low
    • Note: Successful exploitation of this DOM based self XSS requires group admin privileges.

Affected Software

  • ownCloud Server < 4.5.8 (CVE-2013-1822)

Action Taken

It is recommended that all instances are upgraded to ownCloud Server 4.5.8.

Acknowledgements

The ownCloud team thanks the following people for their research and responsible disclosure of the above advisory:

  • Lukas Reschke – ownCloud Inc. (lukas@owncloud.org) – Vulnerability discovery and disclosure.

Share this

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close