< go back to overview

Multiple reflected XSS

Platform: ownCloud Server

Versions: 4.0.2,

Date: 7/11/2012

Risk level: Medium

Description

Multiple cross-site scripting (XSS) vulnerabilities in ownCloud before 4.0.2 allow remote attackers to inject arbitrary web script or HTML via

  • file names to apps/user_ldap/settings.php
  • url or title parameter to apps/bookmarks/ajax/editBookmark.php
  • tag or page parameter to apps/bookmarks/ajax/updateList.php
  • identity to apps/user_openid/settings.php
  • stack name in apps/gallery/lib/tiles.php
  • root parameter to apps/gallery/templates/index.php
  • calendar displayname in apps/calendar/templates/part.import.php
  • calendar uri in apps/calendar/templates/part.choosecalendar.rowfields.php
  • title, location, or description parameter in apps/calendar/lib/object.php
  • certain vectors in core/js/multiselect.js
  • artist, album, or title comments parameter in apps/media/lib_scanner.php

Affected Software

  • ownCloud Server < 4.0.2 (CVE-2012-4395)

Action Taken

It is recommended that all instances are upgraded to ownCloud Server 4.0.2.

Acknowledgements

The ownCloud team thanks the following people for their research and responsible disclosure of the above advisory:

  • Lukas Reschke – ownCloud Inc. (lukas@owncloud.org) – Vulnerability discovery and disclosure.

Share this

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close