< go back to overview

Insecure Flash Cross Domain policies

Platform: ownCloud Server

Versions: 5.0.15, 6.0.2,

Date: 7/3/2014

Risk level: High

Description

Due to insecure Flash Cross Domain policies an attacker might gain access to stored files of the user.

Affected Software

  • ownCloud Server < 6.0.2 (CVE-2014-2047)
  • ownCloud Server < 5.0.15 (CVE-2014-2049)

Action Taken

All packaged Flash files have been audited whether they have potentially insecure Cross Domain policies and vulnerable files have been fixed.

Acknowledgements

The ownCloud team thanks the following people for their research and responsible disclosure of the above advisory:

  • Lukas Reschke – ownCloud Inc. (lukas@owncloud.org) – Vulnerability discovery and disclosure.

Share this