< go back to overview

Code execution in /lib/filesystem.php

Platform: ownCloud Server

Versions: 4.0.10, 4.5.5,

Date: 12/20/2012

Risk level: High


Incomplete blacklist vulnerability in lib/filesystem.php in ownCloud before 4.0.9 and 4.5.2 allows authenticated remote attackers to execute arbitrary code by uploading a file with a special crafted filename.

Affected Software

  • ownCloud Server < 4.0.10 (CVE-2013-5665)
  • ownCloud Server < 4.5.5 (CVE-2013-5665)

Action Taken

It is recommended that all instances are upgraded to ownCloud Server 4.5.5 or 4.0.10.


The ownCloud team thanks the following people for their research and responsible disclosure of the above advisory:

  • Lukas Reschke – ownCloud Inc. (lukas@owncloud.org) – Vulnerability discovery and disclosure.

Share this

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.