Multiple XSS vulnerabilities (oC-SA-2013-028)


AFFECTED SOFTWARE

  • ownCloud Server < 5.0.7 (CVE-2013-2150, CVE-2013-2149)
  • ownCloud Server < 4.5.12 (CVE-2013-2150, CVE-2013-2149)
  • ownCloud Server < 4.0.16 (CVE-2013-2149)

RISK

  • Medium

COMMITS

CVE-2013-2150

CVE-2013-2149

DESCRIPTION

Cross-site scripting (XSS) vulnerabilities in js/viewer.js inside the files_videoviewer application via multiple unspecified vectors in all ownCloud versions prior to 5.0.7 and 4.5.12 allows authenticated remote attackers to inject arbitrary web script or HTML via shared files. (CVE-2013-2150)

Cross-site scripting (XSS) vulnerabilities in core/js/oc-dialogs.js via multiple unspecified vectors in all ownCloud versions prior to 5.0.7 and other versions before 4.0.16 allows authenticated remote attackers to inject arbitrary web script or HTML via shared files. (CVE-2013-2149)

Credits

The ownCloud Team would like to thank Mateusz Goik (aliantsoft.pl / CVE-2013-2149 / CVE-2013-2150) for discovering this vulnerabilities.

RESOLUTION

Update to ownCloud Server 5.0.7, 4.5.12 or 4.0.16
http://download.owncloud.org/community/owncloud-5.0.7.tar.bz2
http://download.owncloud.org/community/owncloud-4.5.12.tar.bz2
http://download.owncloud.org/community/owncloud-4.0.16.tar.bz2